Windows 10 Pro 1809 Autopilot – The parameter is incorrect

I recently ran into an issue where I was using Windows 10 Pro 1809 media and before “Account setup” step in the enrollment status page in Autopilot, I kept seeing the error “The parameter is incorrect”

paramater001

paramater000

This error only occurred for me in Windows 10 Pro 1809, and not in Windows 10 Pro 1903.

In the Event Logs in Applications and Services Logs > Microsoft > Windows > DeviceManagement-Enterprise-Diagnostics > Admin I saw:

MDM Session: Failed to get AAD Token for sync session User Token: (The parameter is incorrect.) Device Token: (Incorrect function.).

Long story short, I kept removing Device Configuration profiles I had assigned to the device, and the policy causing the issue was to upgrade Pro to Enterprise using an MAK key using the “Edition upgrade” policy.

paramter01

To get rid of this error using Autopilot for Windows 10 Pro 1809, with a policy to upgrade to Enterprise, was to either use subscription based licensing assigned to the user, or to use Windows 10 Pro 1903.

The policy above caused a reboot on Windows 10 Pro 1809.

https://docs.microsoft.com/en-us/intune/windows-enrollment-status

A reboot during Device setup will force the user to enter their credentials before transitioning to Account setup phase. User credentials aren’t preserved during reboot. Have the user enter their credentials then the Enrollment Status Page can continue.

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s